Ask Your Question
1

Upgrade from 0.7.5 (and other earlier versions) to 0.10.x

asked 2017-02-04 13:08:13 -0500

updated 2017-03-02 15:08:48 -0500

Evgeny gravatar image

I have been trying to follow the instructions from the upgrade page on askbot website.

Everything worked fine until the last step. When I upgraded from 0.8.1 to the next version. pip install askbot<1.0 installed version 0.10.1 and Django 1.8.17. But my database wasn't ready for Django 1.8. It was giving me the following error:

System check identified 2 issues (0 silenced).
There is no South database module 'south.db.postgresql_psycopg2' for your database. Please either choose a supported database, check for SOUTH_DATABASE_ADAPTER[S] settings, or remove South from INSTALLED_APPS.

I tried to downgrade askbot to 0.9 and Django to 1.7. Then the problem was pytz2013b0 was installed and the self check test says pytz2013b was required. But I couldn't install pytz2013b.

Any suggestions how to move forward?

Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-02-14 08:56:55 -0500

Evgeny gravatar image

updated 2017-03-02 14:50:34 -0500

The process is documented here: https://github.com/ASKBOT/askbot-deve...

The documentation is tested with versions 0.7.58, 0.8.2, 0.9.3, 0.10.2 (released on March 1, 2017).

edit flag offensive delete link more
0

answered 2017-02-10 22:55:23 -0500

updated 2017-03-10 13:07:53 -0500

I was able to find a solution. When downgrading to 0.9 series, I used pip install 'askbot==0.9.1' instead of pip install 'askbot==0.9', which I was using before. Installing version 0.9.1 removed pytz2013b0 problem, and version 0.9.1 also worked with my current database. So the key here was to say explicitly 0.9.1 when downgrading askbot.

Here are all the steps I did:

  • Make sure my Django version was at least 1.5 or 1.6:

    pip uninstall django
    pip install 'django<1.7'
    
  • Upgrade askbot to the latest version of 0.8 series:

    pip uninstall askbot
    pip install 'askbot<0.9'
    
  • Modify the settings.py file. Directions were given when I ran the database migrations. The database migrations:

    python manage.py migrate
    
  • Upgrade Askbot again to 0.9.1

    pip uninstall askbot
    pip install 'askbot==0.9.1'
    
  • Modify settings.py and finally run the database migration:

    python manage.py migrate
    

Now I have Askbot 0.9.1 running on Django 1.7. Please note that I decided to stay with 0.9.1 instead of going to 0.10.1.

Note: Just to follow up. Based on @Evgeny's answer above, I followed the instructions from https://github.com/ASKBOT/askbot-deve... and was able to upgrade to 0.10.2 with no problems.

Here is what I did:

    virtualenv env --no-site-packages
    source env/bin/activate
    pip install 'askbot<0.11'
    askbot-setup #answer questions - use the same database as before
    python manage.py migrate --fake-initial --noinput
    python manage.py collectstatic --noinput
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-02-04 13:08:13 -0500

Seen: 488 times

Last updated: Mar 10