Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version
  • back up your database
  • uninstall askbot app and install the later version (e.g. pip install -U askbot) the actual command will depend on how you've deployed the application.
  • python manage.py syncdb --migrate
  • python manage.py collectstatic --noinput

If during the running of above commands there is an error - the output should follow instructions. Usually they advise to make some changes in the settings.py file.

Other issues may be due to changed dependency libraries whose versions were not hardcoded in Askbot. One known example is django-robots.

For django robots the solution is pip uninstall django-robots & pip install django-robots==1.0

Future releases of askbot (> 0.7.53) will have fixed version requirements for the dependencies.