Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

After copying the django.wsgi file from the /askbot*.egg path the problem went away - not sure why...

This also ensures that the following apache config statement was accurate and so this also then allowed Apache to work with it too

WSGIScriptAlias / /path/to/django-project/django.wsgi

Perhaps this file should be copied as part of the easy_install, pip etc?

Copying /skins from the .egg path was also done so now everything appears to work in Apache.

The following other things caught me out a bit:

1) Because the default database in settings.py is not set to mysql (instead it is set to postgres) an error regarding psycopg2 appears at the start of the process using easy_install askbot. At that point in the installation it is not obvious why - particularly for newbies

2) The log gives MSG: utils.py:get_media_url:145 missing media resource style/extra.css No idea why.

3) The default user cannot view questions. Triggers an error.

After copying the django.wsgi file from the /askbot*.egg path the problem went away - not sure why...

This also ensures that the following apache config statement was accurate and so this also then allowed Apache to work with it too

WSGIScriptAlias / /path/to/django-project/django.wsgi

Perhaps this file should be copied as part of the easy_install, pip etc?

Copying /skins from the .egg path was also done so now everything appears to work in Apache.

The following other things caught me out a bit:

1) Because the default database in settings.py is not set to mysql (instead it is set to postgres) an error regarding psycopg2 appears at the start of the process using easy_install askbot. At that point in the installation it is not obvious why - particularly for newbies

2) The log gives MSG: utils.py:get_media_url:145 missing media resource style/extra.css No idea why.

3) The default user cannot view questions. Triggers an error.

A lack of Karma prevents me uploading, so instead below is the extract from the error log showing the output from 3) that I tried to upload.


Blockquote> /usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/utils.py TIME: 2011-02-18 07:25:47,757 MSG: utils.py:get_media_url:145 missing media resource style/extra.css in skin default /usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/utils.py TIME: 2011-02-18 07:26:00,801 MSG: utils.py:get_media_url:145 missing media resource style/extra.css in skin default /usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/utils.py TIME: 2011-02-18 07:26:03,583 MSG: utils.py:get_media_url:145 missing media resource style/extra.css in skin default /usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/middleware/pagesize.py TIME: 2011-02-18 07:26:03,650 MSG: pagesize.py:process_exception:43 File "/usr/local/lib/python2.6/dist-packages/Django-1.1.2-py2.6.egg/django/core/handlers/base.py", line 99, in get_response response = callback(request, callback_args, *callback_kwargs) File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/views/readers.py", line 559, in question return render_into_skin('question.html', data, request) File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/loaders.py", line 145, in render_into_skin return HttpResponse(template.render(context), mimetype = mimetype) File "/usr/local/lib/python2.6/dist-packages/Coffin-0.3-py2.6.egg/coffin/template/__init__.py", line 51, in render return super(Template, self).render(**context) File "/usr/local/lib/python2.6/dist-packages/Jinja2-2.5.5-py2.6.egg/jinja2/environment.py", line 891, in render return self.environment.handle_exception(exc_info, True) File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/default/templates/question.html", line 2, in top-level template code {% import "macros.html" as macros %} File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/default/templates/two_column_body.html", line 1, in top-level template code {% extends "base.html" %} File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/default/templates/base.html", line 51, in top-level template code {% block body %} File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/default/templates/two_column_body.html", line 5, in block "body" {% block content%} File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/default/templates/question.html", line 308, in block "content" {% set email_feed_frequency = request.user.get_q_sel_email_feed_frequency() %} File "/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/models/__init__.py", line 1279, in user_get_q_sel_email_feed_frequency raise e

/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/middleware/pagesize.py TIME: 2011-02-18 07:26:03,650 MSG: pagesize.py:process_exception:44 <class 'askbot.models.user.doesnotexist'=""> /usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/middleware/pagesize.py TIME: 2011-02-18 07:26:03,651 MSG: pagesize.py:process_exception:45 EmailFeedSetting matching query does not exist. /usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/middleware/pagesize.py TIME: 2011-02-18 07:26:03,651 MSG: pagesize.py:process_exception:54 path: /question/3/is-rh8adfsd-sdfsdf method: GET data: <querydict: {}&gt;="" host:="" community.domain.com="" user:="" root<="" p="">

/usr/local/lib/python2.6/dist-packages/askbot-0.6.68-py2.6.egg/askbot/skins/utils.py TIME: 2011-02-18 07:26:03,670 MSG: utils.py:get_media_url:145 missing media resource style/extra.css in skin default