Ask Your Question
0

Validation_Link doesn't contain correct URL

asked 2013-07-05 05:27:53 -0500

Chankey Pathak gravatar image

updated 2013-07-05 05:32:54 -0500

I used forgot password feature in my site and the link which I got in email doesn't contain correct URL. I checked that it generates from views.py.

'validation_link': site_url(reverse(handler_url_name)) + \ '?validation_code=' + key.

Why is this validation_link not picking site_url correctly? Have I forgot to add site_url somewhere? I have set site name in mywebsite.com/admin to mywebsite.com. Where else do we need to put site url?

Note: It's picking the Site Name correctly like WebSite Name for example.

Greetings from the WebSite Name,

To make use of the Forum, please follow the link below:

:///account/recover/?validation_code=fbde56394ea4cc1fc753a17ff3559a91

Following the link above will help us verify your email address.

If you believe that this message was sent in mistake - no further action is needed. Just ignore this email, we apologize for any inconvenience

Sincerely,
WebSite Name Administrator
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-07-05 07:43:05 -0500

Evgeny gravatar image

The future version will have self-test for the site url (patch committed to the repo).

In your case you should go to "settings->URLs" and set the site url. Make sure the base url ends with a slash (this is autocorrected in the new version too). Second part is /admin/sites/<site_id>/ -> domain name (this is fixed too in the new version, that is the site now needs to be entered only in one place).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-05 05:27:53 -0500

Seen: 315 times

Last updated: Jul 05 '13