Ask Your Question
0

Comments not working on my askbot.com site

asked 2014-06-25 19:56:09 -0600

Mark McClure gravatar image

I have two sites hosted by askbot.com: http://mcmcclur.askbot.com and http://calc3.askbot.com. The second one was set up very recently as a discussion forum for my Summer calculus 3 class. For some reason, I am unable to leave comments on that new site, though I have always been able to do so on the first site and still can. I've fiddled with all the settings and manually increased my Karma but nothing seems to work. Any ideas?

edit retag flag offensive close merge delete

Comments

I'm talking about comments like this one - questions and answers work fine.

Mark McClure gravatar imageMark McClure ( 2014-06-25 19:56:57 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-06-25 20:12:00 -0600

Evgeny gravatar image

The site admin (the site creator is an admin) should always be able to comment. Are you not able to comment from the account with ID=1?

edit flag offensive delete link more

Comments

That is correct.

Mark McClure gravatar imageMark McClure ( 2014-06-25 20:13:50 -0600 )edit

The comment box is there - I fill it out and hit the "add comment" button but the comment never appears.

Mark McClure gravatar imageMark McClure ( 2014-06-25 20:14:56 -0600 )edit

Sorry about that. It's getting late here, will look tomorrow morning.

Evgeny gravatar imageEvgeny ( 2014-06-25 20:15:26 -0600 )edit

Thank you very much!

Mark McClure gravatar imageMark McClure ( 2014-06-25 20:16:24 -0600 )edit

@Evgeny - I figured out this problem or, at least, how to trigger the problem. See my detailed answer and feel free to delete the site referenced therein.

Mark McClure gravatar imageMark McClure ( 2014-08-18 21:25:43 -0600 )edit
0

answered 2014-08-18 21:24:02 -0600

Mark McClure gravatar image

I've figured out what is causing this problem, at least from the user's perspective. The problem seems to be triggered by modifying the "Enable email alerts" option, which is available under

Settings -> Login, Users & Communication -> Email and email alert settings

The default is True - just turn it off and see what happens. In fact, I just created a site specifically to test this out, namely, http://commentbugtest.askbot.com. I started it, asked one question, left one comment, then turned off "Enable email alerts". After that, I was no longer able to leave comments.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-25 19:56:09 -0600

Seen: 184 times

Last updated: Aug 18 '14