Ask Your Question
2

send_unanswered_questions manage command broken?

asked 2016-08-07 20:25:00 -0500

domofactor gravatar image

hey guys,

I've been struggling to get the send_unanswered_questions manage command working successfully.

I'm able to send signup emails successfully. So, my settings.py seems to be correct. Here's what my email section looks like:

SERVER_EMAIL = ''
DEFAULT_FROM_EMAIL = ''
EMAIL_HOST_USER = ''
EMAIL_HOST_PASSWORD = ''
EMAIL_SUBJECT_PREFIX = ''
EMAIL_HOST='<my_host>'
EMAIL_PORT='25'
EMAIL_USE_TLS=False
EMAIL_BACKEND = 'django.core.mail.backends.smtp.EmailBackend' ```

However, when I cd into my app dir and run python manage.py send_unanswered_questions this is the only output I get:

root@e4ac59739b44:/app# python manage.py send_accept_answer_reminders WARNING!!! You are using a 'locmem' (local memory) caching backend, which is OK for a low volume site running on a single-process server. For a multi-process configuration it is neccessary to have a production cache system, such as redis or memcached.

With local memory caching and multi-process setup you might intermittently see outdated content on your site.

System check identified some issues:

WARNINGS: django_authopenid.UserPasswordQueue.user: (fields.W342) Setting unique=True on a ForeignKey has the same effect as using a OneToOneField. HINT: ForeignKey(unique=True) is usually better served by a OneToOneField. group_messaging.SenderList.recipient: (fields.W342) Setting unique=True on a ForeignKey has the same effect as using a OneToOneField. HINT: ForeignKey(unique=True) is usually better served by a OneToOneField.

I tried checking the logfile, and there's no output there either. I'm running Askbot 0.10.1, any help is appreciated. Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-12 09:17:02 -0500

Evgeny gravatar image

updated 2016-08-12 09:17:41 -0500

These warnings don't mean that the command does not work. Are the messages that were supposed to be sent actually not sent. Your email settings look reasonable.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-07 20:20:53 -0500

Seen: 5,285 times

Last updated: Aug 12 '16