Ask Your Question
1

Sometimes I see 404 error

asked 2010-12-24 02:01:26 -0500

sergejdergatsjev gravatar image

updated 2010-12-24 02:37:38 -0500

Evgeny gravatar image

So I change nothing in configuration file but i get random this error. It looks as if all URLs are translated into Russian???

Is it bug? or feature? ;)

I have nothing configured for Russian. (Browser is Google chrome, English)

Page not found (404)
Request Method: GET
Request URL:    http://www.aq6.ru/tags/
Using the URLconf defined in aq6ru.urls, Django tried these URL patterns, in this order:
^$
^sitemap.xml$
^m/(?P<skin>[^/]+)/media/(?P<resource>.*)$
^upfiles/(?P<path>.*)$
^о-нас/$
^часто-задаваемые-вопросы/$
^правила-о-личной-информации/$
^выйти/$
^ответы/(?P<id>\d+)/править/$
^ответы/(?P<id>\d+)/правки/$
^вопросы/$
^вопросы/спросить/$
^вопросы/(?P<id>\d+)/править/$
^вопросы/(?P<id>\d+)/retag/$
^вопросы/(?P<id>\d+)/закрыть/$
^вопросы/(?P<id>\d+)/открыть-снова/$
^вопросы/(?P<id>\d+)/ответить/$
^вопросы/(?P<id>\d+)/голосовать/$
^вопросы/(?P<id>\d+)/правки/$
^post_comments/$
^edit_comment/$
^комманда/$
^comment/delete/$
^comment/get_text/$
^вопрос/(?P<id>\d+)/
^темы/$
^отметить-тему/интересная/(?P<tag>[^/]+)/$
^отметить-тему/неинтересная/(?P<tag>[^/]+)/$
^отменить-отметку-темы/(?P<tag>[^/]+)/$
^люди/$
^люди/(?P<id>\d+)/править/$
^люди/(?P<id>\d+)/(?P<slug>.+)/$
^награды/$
^награды/(?P<id>\d+)//*
^сообщения/отметить-прочитанное/$
^manage_inbox/$
^feeds/(?P<url>.*)/$
^загрузить-файл/$
^искать/$
^обратная-связь/$
^account/
^i18n/
^doc/(?P<path>.*)$
^admin/
^settings/
^robots.txt$
The current URL, tags/, didn't match any of these.
You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 404 page.
edit retag flag offensive close merge delete

Comments

Thanks, by the way. Turns out the i18n url and the LocaleMiddleware are not even necessary, i've removed them from the repo code.
Evgeny gravatar imageEvgeny ( 2010-12-26 15:24:27 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2010-12-24 02:43:28 -0500

Evgeny gravatar image

updated 2010-12-24 02:47:55 -0500

try removing this from the list of urls in the urls.py: -> ^i18n/

and disable django.middleware.locale.LocaleMiddleware in the MIDDLEWARE_CLASSES of your settings.py

the language will not switch spontaneously :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2010-12-24 02:01:26 -0500

Seen: 279 times

Last updated: Dec 24 '10