Ask Your Question

Does askbot work with django version 1.2.3?

asked 2011-02-12 00:28:32 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

I am looking to install this on an Ubuntu machine, and would prefer to install django from apt instead of from easy install. However the installer requires exactly 1.2.2 of django before it will continue. This is too high for Lucid, which distributes django version 1.1.1. But Maverick comes with Django version 1.2.3.

Can I use django 1.2.3? If so how can I tell the pip installer to use the installed version?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2011-02-14 07:02:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

Whilst askbot might work, I'm not sure 'startforum' does - I think there is an issue where it requires django==1.1.2, not django > 1.1.2 (if that is even possible to specify?)

-- Edit-- A quick test shows it does install fine:

(askbot)mcMoo:forum jt$ pip freeze | grep Django
(askbot)mcMoo:forum jt$ startforum

Deploying Askbot - Django Q&A forum application
Problems installing? -> please email

To CANCEL - hit Ctr-C at any time
Where to deploy (in which directory)? .
Copying files: 

copying directories:  doc  cron  upfiles  
Done. Please find further instructions in the file below:
/.. cut .. /INSTALL
edit flag offensive delete link more


Thanks, the 1.2 deployment needs to be tested out, other than that there is no problem changing == to > in the if you don't want to wait - either clone the repository or get the tarball, make the requirement change and run "python install" or "python develop", virtualenv might be a good idea too. I will install 1.2 and work with it for a week or so.
Evgeny's avatar Evgeny  ( 2011-02-14 11:23:49 -0500 )edit
As for the feedback from startforum - there aren't any problems - as far as I can see. All startforum does - copy some files and directories.
Evgeny's avatar Evgeny  ( 2011-02-14 11:26:16 -0500 )edit
Jmons, I've noticed your tweet about askbot - thanks btw - what are the problems you found when integrating with other django apps. We'd like to solve them, but for now it would be helpful to identify those issues. Anything besides the 1.1 requierement?
Evgeny's avatar Evgeny  ( 2011-02-14 12:08:09 -0500 )edit

answered 2011-02-12 00:52:34 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >100 is welcome to improve it.

edit: OK, I remember now what was the problem with 1.2 - need to change requirement to use Coffin library version 0.3.3, the default requirement is 0.3.

Give it a shot, a while ago someone tested askbot with 1.2 and it worked. I have not tested yet myself.

For safety - not to affect your site-wide python libraries - you might create a virtual environment

virtualenv /path/to/new/env  --no-site-packages

Then run

/path/to/new/env/bin/pip install askbot

Then using a similar command install the version of django that you would like to use:

/path/to/new/env/bin/pip install django==1.2.3

If you find any barring issues, please tell about them, but hopefully it will just work.

Askbot ships with file where versions of some dependencies are very specific. You can override them by editing the, then run /path/to/your/virtual/env/python install.

There is also option python develop - useful when you clone code from the repo and plan to use git to maintain your customizations (like skin).

After installing it is possible to run tests python test askbot - works much faster with postgres. Two or three tests will fail because there is some missing test data, but the remaining tests should pass.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2011-02-12 00:28:32 -0500

Seen: 1,365 times

Last updated: Feb 15 '11