Ask Your Question
2

psycopg2 - support for version 2.4.2

asked 2011-10-31 12:26:03 -0600

Aditya gravatar image

updated 2012-01-31 09:11:13 -0600

Evgeny gravatar image

Looking at the askbot pre-requisites, it requires version 2.4.1. however, most hosting platforms such as gondor.io and ep.io etc support 2.4.2

This is because, version 2.4.1 is claimed to have bugs.

What, if any, is the plan to support 2.4.2?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-27 06:41:59 -0600

slankes gravatar image

The fact that askbot is refusing to start with psycopg2 2.4.2 means that it doesn't work on a Fedora 16 install which ships 2.4.2.

I have patched out the version query and was unable to find any issues during casual use of my local askbot instance.

edit flag offensive delete link more

Comments

We're not refusing to fix this, we'll get there.

Evgeny gravatar imageEvgeny ( 2011-11-27 15:19:36 -0600 )edit

No - sorry. I didn't want to imply that you're refusing to fix it. Maybe you could change the startup routine to print a warning and start anyway?

slankes gravatar imageslankes ( 2011-11-28 01:28:54 -0600 )edit

Removed the startup routine now. The test cases pass... The problem was quite obscure and it might have gone away with the changes in the db schema/queries.

Evgeny gravatar imageEvgeny ( 2011-11-28 07:20:18 -0600 )edit
0

answered 2011-10-31 14:51:36 -0600

Evgeny gravatar image

updated 2011-11-28 12:42:04 -0600

edited apparently this is no longer a problem (not 100% sure yet though).

We did remove the requirement of a specific version for the psycopg2 module - (in version 0.7.30), if there are any issues - please let us know.

edit flag offensive delete link more
0

answered 2012-01-31 09:06:58 -0600

@Evgeny: The requirement is still documented on http://askbot.org/doc/create-database.html though. Should it be removed there?

(Sorry for the answer, can't comment due to not enough karma yet.)

edit flag offensive delete link more

Comments

Actually, it is no longer required (may be required to run tests, but not for the production use). Note taken - removed the clause from the doc - will be available in the next release.

Evgeny gravatar imageEvgeny ( 2012-01-31 09:09:43 -0600 )edit

Thank you!

robinst gravatar imagerobinst ( 2012-02-01 06:02:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-31 12:26:03 -0600

Seen: 193 times

Last updated: Jan 31 '12