Ask Your Question
1

Why is askbot incompatible with jQuery 1.7?

asked 2012-02-21 11:50:56 -0500

piskvorky gravatar image

updated 2012-02-21 14:06:35 -0500

Evgeny gravatar image

In general, jquery should be backward-compatible, so I tried bumping askbot jquery from 1.4.3 to 1.7.1.

I immediately got a "jQuery.handleError is not a function" error (when uploading an image), maybe there are other errors too. Apparently askbot uses some jquery 1.4.3 features that disappeared in later versions.

Are these features vital? Are there plans to support a newer jquery release?

edit retag flag offensive close merge delete

Comments

Hey, I've edited your title a bit.

Evgeny gravatar imageEvgeny ( 2012-02-21 14:07:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-02-21 14:05:33 -0500

Evgeny gravatar image

From what people say about jQuery it does seem to be backwards compatible.

Maybe the issues we have are due to incompatibility in the plugins and possibly our own code, I think there is no magic solution here, but to debug the code.

We probably should isolate javascript used in askbot into a separate namespace, so that we could use whatever version we want, without competing with other code.

I don't know when this will be done, at this moment this is not the highest priority.

edit flag offensive delete link more

Comments

2

Ok, thanks. For the moment, I "solved" the problem by using both jquery versions at once, using the $.noConflict(); syntax.

piskvorky gravatar imagepiskvorky ( 2012-02-22 04:30:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-21 11:50:56 -0500

Seen: 188 times

Last updated: Feb 21 '12