Ask Your Question


asked 2013-01-17 09:06:21 -0600

Fabien Meghazi's avatar

Trying to make a custom skin and after reading the askbot/skins/README, I added this line in

#ASKBOT_EXTRA_SKINS_DIR = os.path.join(os.path.dirname(__file__), 'askbot', 'skins')

... and here is the directory structure. base.html was just copied from askbot module

└── test
    ├── media
    └── templates
        └── base.html

2 directories, 1 file

Now I restart the uwsgi I hit the application trough a browser and in the uwsgi application log file (where I use to see application tracebacks) I have this :

Thu Jan 17 15:55:53 2013 - DAMN ! worker 1 (pid: 1502) died :( trying respawn ...
Thu Jan 17 15:55:53 2013 - Respawned uWSGI worker 1 (new pid: 1514)
Thu Jan 17 15:55:53 2013 - DAMN ! worker 2 (pid: 1509) died :( trying respawn ...
Thu Jan 17 15:55:53 2013 - Respawned uWSGI worker 2 (new pid: 1515)

No error, no traceback, nothing. As the application does not respond, nginx end up with a 502 Bad Gateway

Did I do something wrong with the changes I mentioned here before ?

Is the skin system in beta state ?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-01-18 14:40:10 -0600

Evgeny's avatar

updated 2013-01-18 14:41:26 -0600

There is nothing wrong with your settings, but I would start with testing with the django runserver, instead of nginx/uwsgi. If you show that "runserver" works then you know that there is nothing wrong with the setup of the django apps.

I think you have some unrelated issues in your deployment.

edit flag offensive delete link more


You're right. I forgot about running in strandalone in order to have helpful debug information. This topic helped me too :

Fabien Meghazi's avatar Fabien Meghazi  ( 2013-01-21 06:47:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2013-01-17 09:06:21 -0600

Seen: 457 times

Last updated: Jan 18 '13