Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

multilingual=true crashes

On askbot 0.7.49 , we are seeing this crash on turning multilingual=true in settings.py

[Thu Nov 14 14:05:49 2013] [error]
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88] mod_wsgi (pid=31744): SystemExit exception raised by WSGI script '/usr/sbin/askbot.wsgi' ignored.
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88] Traceback (most recent call last):
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/django/core/handlers/wsgi.py", line 219, in __call__
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     self.load_middleware()
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/django/core/handlers/base.py", line 45, in load_middleware
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     mod = import_module(mw_module)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     __import__(name)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/askbot/middleware/view_log.py", line 7, in <module>
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     from askbot.models import signals
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/askbot/models/__init__.py", line 2, in <module>
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     startup_procedures.run()
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/django/db/transaction.py", line 224, in inner
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     return func(*args, **kwargs)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]   File "/usr/lib/python2.6/site-packages/askbot/startup_procedures.py", line 1061, in run
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]     sys.exit(1)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88] SystemExit: 1

multilingual=true crashes

On askbot 0.7.49 , we are seeing this crash on turning multilingual=true in settings.py

 [Thu Nov 14 14:05:49 2013] [error]
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]  mod_wsgi (pid=31744): SystemExit exception raised by WSGI script '/usr/sbin/askbot.wsgi' ignored.
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]  Traceback (most recent call last):
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/django/core/handlers/wsgi.py", line 219, in __call__
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      self.load_middleware()
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/django/core/handlers/base.py", line 45, in load_middleware
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      mod = import_module(mw_module)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      __import__(name)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/askbot/middleware/view_log.py", line 7, in <module>
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      from askbot.models import signals
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/askbot/models/__init__.py", line 2, in <module>
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      startup_procedures.run()
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/django/db/transaction.py", line 224, in inner
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      return func(*args, **kwargs)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]    File "/usr/lib/python2.6/site-packages/askbot/startup_procedures.py", line 1061, in run
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]      sys.exit(1)
[Thu Nov 14 14:05:49 2013] [error] [client 10.5.126.88]  SystemExit: 1

Please check.