Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

setup avatar error

I have followed the instructions on setting up avatar, but I get the following error:

[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] mod_wsgi (pid=11680): Exception occurred processing WSGI script '/../../../..//django.wsgi'.
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] Traceback (most recent call last):
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]   File "/../../../local/lib/python2.7/site-packages/Django-1.4.10-py2.7.egg/django/core/handlers/wsgi.py", line 219, in __call__
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]     self.load_middleware()
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]   File "/../../..//local/lib/python2.7/site-packages/Django-1.4.10-py2.7.egg/django/core/handlers/base.py", line 47, in load_midd
leware
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]     raise exceptions.ImproperlyConfigured('Error importing middleware %s: "%s"' % (mw_module, e))
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] ImproperlyConfigured: Error importing middleware askbot.middleware.anon_user: "No module named avatar"

I have already added into installed apps, and have done everything mentioned in this link: http://askbot.org/doc/optional-modules.html#uploaded-avatars

click to hide/show revision 2
No.2 Revision

setup avatar errorerror "no module named Avatar"

I have followed the instructions on setting up avatar, but I get the following error:

[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] mod_wsgi (pid=11680): Exception occurred processing WSGI script '/../../../..//django.wsgi'.
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] Traceback (most recent call last):
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]   File "/../../../local/lib/python2.7/site-packages/Django-1.4.10-py2.7.egg/django/core/handlers/wsgi.py", line 219, in __call__
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]     self.load_middleware()
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]   File "/../../..//local/lib/python2.7/site-packages/Django-1.4.10-py2.7.egg/django/core/handlers/base.py", line 47, in load_midd
leware
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]     raise exceptions.ImproperlyConfigured('Error importing middleware %s: "%s"' % (mw_module, e))
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] ImproperlyConfigured: Error importing middleware askbot.middleware.anon_user: "No module named avatar"

I have already added into installed apps, and have done everything mentioned in this link: http://askbot.org/doc/optional-modules.html#uploaded-avatars

setup avatar error "no module named Avatar"

I have followed the instructions on setting up avatar, but I get the following error:

[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] mod_wsgi (pid=11680): Exception occurred processing WSGI script '/../../../..//django.wsgi'.
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] Traceback (most recent call last):
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]   File "/../../../local/lib/python2.7/site-packages/Django-1.4.10-py2.7.egg/django/core/handlers/wsgi.py", line 219, in __call__
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]     self.load_middleware()
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]   File "/../../..//local/lib/python2.7/site-packages/Django-1.4.10-py2.7.egg/django/core/handlers/base.py", line 47, in load_midd
leware
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71]     raise exceptions.ImproperlyConfigured('Error importing middleware %s: "%s"' % (mw_module, e))
[Tue Jan 21 15:20:53 2014] [error] [client 128.101.35.71] ImproperlyConfigured: Error importing middleware askbot.middleware.anon_user: "No module named avatar"

I have already added into installed apps, and have done everything mentioned in this link: http://askbot.org/doc/optional-modules.html#uploaded-avatars

When I installed using pip install I was in virtualenv and after the installation the avatar was install in src folder within my virtualenv.

bin  askbotApp  include  lib  local  src

/src/django-avatar$
avatar  CHANGELOG  CONTRIBUTORS.txt  django_avatar.egg-info  docs  LICENSE.txt  MANIFEST.in  README.txt  setup.py  tests