Ask Your Question
0

HTTPS-only on Apache: Redirects to HTTP

asked 2013-11-19 10:28:04 -0600

c_j_walesch gravatar image

I configured askbot on apache/wsgi with https only. When I enter the base url https: //myserver.com/ask/ in a browser, I get redirected to http: //myserver.com/ask/questions/. This gets my a 404, because didn't (and don't want to) configure http.

My config:

<VirtualHost 1.2.3.4:443>
 ServerAdmin root@myserver.com
 DocumentRoot /srv/askbotqa
 ServerName myserver.com

 SSLEngine on
 SSLCertificateFile /etc/apache2/ssl/server.crt
 SSLCertificateKeyFile /etc/apache2/ssl/server.key

 Alias /admin/media/ /usr/local/lib/python2.6/site-packages/django/contrib/admin/media/
 WSGIScriptAlias /ask/ /srv/askbotqa/django.wsgi

 CustomLog /var/log/httpd/askbot/access_log common
 ErrorLog /var/log/httpd/askbot/error_log
</VirtualHost>

How can I make it work with https only?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-19 10:33:50 -0600

Evgeny gravatar image

Maybe you don't have Listen 443 in the main configuration? Or redirect is handled by something before Apache has a chance to make a response? Have a look at the apache config file and the logs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-19 10:28:04 -0600

Seen: 301 times

Last updated: Nov 19 '13