Ask Your Question
0

How to fix "SystemExit" error in the startup_procedures?

asked 2012-11-24 14:15:45 -0500

andreysolo gravatar image

updated 2012-11-24 14:44:18 -0500

Evgeny gravatar image

After installation I see the error in the log:

 [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1] mod_wsgi (pid=12194): SystemExit exception raised by WSGI script '/home/scriptology/webapps/django_forum/myproject/myproject/wsgi.py' ignored.
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1] Traceback (most recent call last):
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/webapps/django_forum/lib/python2.7/django/core/handlers/wsgi.py", line 219, in __call__
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     self.load_middleware()
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/webapps/django_forum/lib/python2.7/django/core/handlers/base.py", line 45, in load_middleware
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     mod = import_module(mw_module)
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/webapps/django_forum/lib/python2.7/django/utils/importlib.py", line 35, in import_module
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     __import__(name)
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/lib/python2.7/askbot-0.7.44-py2.7.egg/askbot/middleware/view_log.py", line 7, in <module>
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     from askbot.models import signals
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/lib/python2.7/askbot-0.7.44-py2.7.egg/askbot/models/__init__.py", line 2, in <module>
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     startup_procedures.run()
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/webapps/django_forum/lib/python2.7/django/db/transaction.py", line 209, in inner
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     return func(*args, **kwargs)
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]   File "/home/scriptology/lib/python2.7/askbot-0.7.44-py2.7.egg/askbot/startup_procedures.py", line 886, in run
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1]     sys.exit(1)
        [Sat Nov 24 14:04:10 2012] [error] [client 127.0.0.1] SystemExit: 1

How to fix the problem?

edit retag flag offensive close merge delete

Comments

Have you tried running with django's runserver? Also - of the two of your questions - could you delete one please, they look the same.

Evgeny gravatar imageEvgeny ( 2012-11-24 14:20:18 -0500 )edit

Yes. I see the message: 1) Add to STATICFILES_DIRS the following entry: ('default / media', os.path.join (ASKBOT_ROOT, 'media')),

2) Run command (after fixing the above errors)      python manage.py collectstatic

andreysolo gravatar imageandreysolo ( 2012-11-24 14:34:58 -0500 )edit

Is this an upgrade or a new install? Have you tried to do what the messages suggest?

Evgeny gravatar imageEvgeny ( 2012-11-24 14:37:01 -0500 )edit

Package askbot took here https://github.com/ASKBOT/askbot-девел Yes, all the tasks of the message made.

andreysolo gravatar imageandreysolo ( 2012-11-24 14:41:21 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-03-01 20:19:01 -0500

Sindbad gravatar image

add this command on your settings.py file

ASKBOT_SELF_TEST = False

and
try this : "python manage.py collectstatic"
try this : "python manage.py syncdb --migrate --noinput"

edit flag offensive delete link more
0

answered 2012-11-24 14:48:48 -0500

Evgeny gravatar image

The startup procedures test your setup configuration, and in the case of error give you feedback about what can be incorrect and what can be done to fix the issues.

The best thing I can suggest is to make sure that the site works with the django's built-in webserver, which can be started with a command:

python manage.py runserver #if you run from your local computer or
python manage.py runserver  <ip_address/domain_name>:<port number> #for a remote server

After your site works this way - create a production deployment.

edit flag offensive delete link more

Comments

^C[scriptology@web325 myproject]$ python2.7 manage.py runserver 95.211.73.1:8000 Validating models...

Your output encoding is not UTF-8, there may be issues with the software when anything is printed to the terminal or log files


  • *
  • Askbot self-test *
  • *

Please attend to the following:

1) Add to STATICFILES_DIRS the following entry: ('default/media', os.path.join(ASKBOT_ROOT, 'media')),

2) Run command (after fixing the above errors) python manage.py collectstatic

andreysolo gravatar imageandreysolo ( 2012-11-24 15:17:50 -0500 )edit

all is done, but the messages are still

andreysolo gravatar imageandreysolo ( 2012-11-24 15:19:34 -0500 )edit

Can you show your STATICFILES_DIRS? I think there is still some error.

Evgeny gravatar imageEvgeny ( 2012-11-24 15:23:31 -0500 )edit

my: STATICFILES_DIRS = ( ('default/media', os.path.join(ASKBOT_ROOT, 'media')), )

andreysolo gravatar imageandreysolo ( 2012-11-24 15:26:18 -0500 )edit

Ok, looks right. What is your version of askbot? How did you download the software. Can you email me your settings.py? (support@askbot.com).

Evgeny gravatar imageEvgeny ( 2012-11-24 15:31:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-24 14:15:45 -0500

Seen: 1,723 times

Last updated: Mar 01 '15