How to configure Askbot to run behind reverse-proxy ?

asked 2014-02-21 04:24:51 -0600

alci gravatar image

updated 2014-02-21 05:13:34 -0600

I have Askbot setup on a server, and running fine on our internal network. Now I need to make it available in our extranet, meaning make the server accessible from the internet.

I have an Apache2 server with reverse-proxy acting as an entry point for our extranet applications, with several of them already running (vtiger, wordpress, roundcube, ...).

So I am trying to get Askbot working from behind this reverse proxy.

Here is my setup on the reverse-proxy:

<VirtualHost *:443>
    ServerName mydomain.com
    ServerAlias www.mydomain.com
    SSLEngine on
    SSLCertificateFile    /etc/ssl/certs/mydomain.com.crt
    SSLCertificateKeyFile /etc/ssl/private/mydomain.com.key
    SSLCertificateChainFile /etc/ssl/certs/mydomain.com.ca-bundle
    SSLProxyEngine On

    <Location /evolution>
            ProxyPass h t t p://192.168.1.17/
            ProxyPassReverse h t t p://192.168.1.17/
    </Location>
</VirtualHost>

On the Askbot side, I have set this in BaseURL:

BaseURL h t t p://192.168.1.17/evolution/"

When coming from the internet, I get the following error:

The requested URL /evolutionaccount/signin/ was not found on this server.

A slash is missing. Adding it manually in my url make things kind of work, that I get the page, altough the css seems to be missing...

So here is my question: how should I setup Askbot to work behind my reverse-proxy (maybe some parameter in settings.py?)

edit retag flag offensive close merge delete