cannot navigate away with Firefox 3.6.11 beta

asked 2010-10-11 12:50:47 -0500

niles gravatar image

updated 2010-11-10 11:55:11 -0500

Evgeny gravatar image

UPDATE: Apparently this was a problem with the firefox 3.6.11 beta; with the release version of 3.6.11 I no longer have this problem.

I don't know if this is a bug with Firefox or askbot, but it is pretty surprising behavior. I reported the following to Mozilla, but decided I might mention it here too:

I installed Firefox 3.6.11 beta today. When I visit the sites

http://askbot.org

or

http://ask.sagemath.org

I cannot navigate away using the URL bar or search box: using either seems to behave as if I had used the search feature for that site.

3 further notes:

  • I use these sites regularly and have not encountered this behavior before

  • Clicking a bookmark in my bookmark toolbar does take me to the expected page (away from the site)

  • I do not have this behavior on stackexchange sites like mathoverflow.net or stackoverflow.com

thanks!

edit retag flag offensive close merge delete

Comments

Do you have this problem if you type in the browser address bar: http://askbot.org/en/questions/ ? If the issue goes away, it will mean that the problem is in the redirects. The '/' automatically redirects to '/questions/', maybe it's better not to redirect at all.
Evgeny gravatar imageEvgeny ( 2010-10-11 13:40:33 -0500 )edit
Yes, I seem to have this problem no matter what I type into the address bar; there have been a couple of cases where I managed to navigate away, but I can't reproduce them :(
niles gravatar imageniles ( 2010-10-11 15:47:05 -0500 )edit
(so I think this must be a Firefox beta problem)
niles gravatar imageniles ( 2010-10-11 15:47:26 -0500 )edit
I have no problem like this one at 3.6.10. It may be Firefox bug indeed, but let's see if others have this problem too.
Evgeny gravatar imageEvgeny ( 2010-10-11 16:09:14 -0500 )edit