how should email be configured to overcome "/usr/local/lib/python2.6/dist-packages/askbot/utils/mail.py TIME: 2011-02-15 15:10:25,261 MSG: mail.py:send_mail:48 please run connect() first"?

asked 2011-02-15 18:09:37 -0500

tfoote gravatar image

updated 2011-02-15 18:32:55 -0500

Evgeny gravatar image

I am getting this error in my askbot.log "/usr/local/lib/python2.6/dist-packages/askbot/utils/mail.py TIME: 2011-02-15 15:10:25,261 MSG: mail.py:send_mail:48 please run connect() first"

I'm running django 1.1.2 on Maverick.

I have the following email settings: {{{

mail server settings

SERVER_EMAIL = 'root@answers.ros.org' DEFAULT_FROM_EMAIL = 'root@answers.ros.org' EMAIL_HOST_USER = '' EMAIL_HOST_PASSWORD = '' EMAIL_SUBJECT_PREFIX = '' EMAIL_HOST='localhost' EMAIL_PORT='25' EMAIL_USE_TLS=False EMAIL_BACKEND = 'django.core.mail.backends.smtp.EmailBackend' }}}

edit retag flag offensive close merge delete

Comments

Your settings look right, but the mail server must be running and accept those credentials. Sorry, I am not an expert in mailserver configuration - hope that someone else helps. My settings are as follows: SERVER_EMAIL = '' DEFAULT_FROM_EMAIL = 'askbot@askbot.org' EMAIL_HOST_USER = '' EMAIL_HOST_PASSWORD = '' EMAIL_SUBJECT_PREFIX = '[ASKBOT] ' EMAIL_HOST='askbot.org' EMAIL_PORT='25' EMAIL_USE_TLS=False EMAIL_BACKEND = 'django.core.mail.backends.smtp.EmailBackend' But I might have missed something, the difference I see with your settings is that you have "localhost" and I have domain name in the `EMAIL_HOST` setting.

Evgeny gravatar imageEvgeny ( 2011-02-15 18:21:48 -0500 )edit
btw - there is a code formatting button in the editor toolbar. Something you'll probably need to teach your users about too.
Evgeny gravatar imageEvgeny ( 2011-02-15 18:23:07 -0500 )edit
A couple of questions: When do you get this error - at what operation on the forum? Do you see error 500 screen or on-screen debug traceback - or is it part of the error log file?
Evgeny gravatar imageEvgeny ( 2011-02-15 18:27:37 -0500 )edit
Changing the last line to match fixed it. Thanks
tfoote gravatar imagetfoote ( 2011-02-15 18:53:35 -0500 )edit
Ooopss, sorry the last line I had is a mistake!
Evgeny gravatar imageEvgeny ( 2011-02-15 18:54:33 -0500 )edit