Ask Your Question
1

How to change askbot skin ?

asked 2011-09-04 05:46:52 -0500

AlexP gravatar image

updated 2011-09-04 06:20:43 -0500

Hey,

I've modified Askbot skin and place it in an other foler (/home/name/myskin) and created a symbolic link (ln -s) from this folder to askbot/skins/myskins.

Now I would like to know how to use this new skin by default ?

Thank you :)

Edit : in settings, under Skins tab, myskin doesn't appear in the select menu to choose skin.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-09-04 07:17:58 -0500

Evgeny gravatar image

Try adding ASKBOT_EXTRA_SKINS_DIR setting to your settings.py as described here.

Please post an update if it does not help.

edit flag offensive delete link more

Comments

set skin path to ASKBOTEXTRASKINS_DIR works for me

byron gravatar imagebyron ( 2011-09-22 01:38:14 -0500 )edit
0

answered 2011-09-04 07:25:56 -0500

AlexP gravatar image

I've defined ASKBOT_EXTRA_SKINS_DIR as follow :

ASKBOT_EXTRA_SKINS_DIR = '/home/name'

with and without trailling slash, but myskin still doesn't appear in settings. I've check the folder syntax, and it has the required folders.

edit flag offensive delete link more

Comments

1

Hmm, works for me, probably your directory path is incorrect... I have dir /home/username/extraskins, and inside extraskins have the skin directory myskin. The ASKBOT_EXTRA_SKINS_DIR = '/home/username/extraskins' and the skin works - both appears in the dropdown and loads correct templates & media.

Evgeny gravatar imageEvgeny ( 2011-09-04 15:23:38 -0500 )edit

I've check directory structure, and as it's base on default, it has the exact same one. I also checked the CHMOD of the directory structure, and it seems good for me (apache:apache). I don't know what may cause the problem now ...

Do I have to restart server after doing a change ? If yes, how ?

AlexP gravatar imageAlexP ( 2011-09-05 03:58:51 -0500 )edit

Does it work with python manage.py runserver? One way to restart apache is /etc/init.d/httpd restart or /etc/init.d/apache2 restart depending on the system and the version of the webserver.

Evgeny gravatar imageEvgeny ( 2011-09-05 07:40:07 -0500 )edit

I just had to restart the server with "service httpd restart" and the skin appears in the list and the media are correctly loaded.

Thank you for your help !

AlexP gravatar imageAlexP ( 2011-09-05 07:57:59 -0500 )edit

Hey, is it possible to mark a comment as favorite? So I can mark this problem as solved

AlexP gravatar imageAlexP ( 2011-09-11 09:05:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-04 05:46:52 -0500

Seen: 1,289 times

Last updated: Sep 04 '11