Ask Your Question
0

Which version of Python (2.4? 2.5? 2.6?) is necessary?

asked 2011-11-24 01:55:08 -0500

Joseph gravatar image

Which version of Python (2.4? 2.5? 2.6?) is necessary for AskBot?

Which version of Python is recommended?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-24 07:33:28 -0500

Evgeny gravatar image

Joseph, 2.5 or higher, but 2.7 - the highest available version is best because it is the fastest of all Python 2.x.

On my development box I have 2.6, ve have not run tests on different versions recently, but if something breaks we will fix instantly.

edit flag offensive delete link more

Comments

On github/askbot I saw tox.ini, with py2.5, 2.6 and 2.7 in it. I assumed you were running tox automatically :)

piskvorky gravatar imagepiskvorky ( 2011-11-25 13:39:17 -0500 )edit

not recently, but we will return to doing that regularly.

Evgeny gravatar imageEvgeny ( 2011-11-25 13:40:29 -0500 )edit

So 2.4 is not supported? Or you haven't tested it?

Joseph gravatar imageJoseph ( 2011-11-28 03:57:30 -0500 )edit

Python 2.4 will not work, tested that. We are unlikely to try fixing this.

Evgeny gravatar imageEvgeny ( 2011-11-28 07:39:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-24 01:55:08 -0500

Seen: 190 times

Last updated: Nov 24 '11