Ask Your Question
0

changing the logo on settings/GENERAL_SKIN_SETTINGS/ doesn't work

asked 2011-12-11 17:36:58 -0500

quesada gravatar image

It simply displays an empty image spot, so it's clear that there is supposed to be an image there... but the image is not shown. I've tried with .jpg and .gif. In fact, I've tried downloading the askbot logo, and uploading it again on that setting, to have the closest thing to the original set up. Still no logo displayed.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-12-11 18:35:28 -0500

Evgeny gravatar image

Works on my development machine, I think you must have issues the deployment, probably one of the settings in your settings.py:

  • CSRF_COOKIE_DOMAIN setting value
  • FILE_UPLOAD_TEMP_DIR - either setting value or permissions
  • ASKBOT_FILE_UPLOAD_DIR
  • ASKBOT_UPLOADED_FILES_URL
edit flag offensive delete link more

Comments

Yes, the ASKBOT_UPLOADED_FILES_URL was wrong, thanks Evgeny. Btw there is still a bug in serving uploaded files (unrelated to this question): https://github.com/piskvorky/askbot-devel/commit/dc018de842a019caf40e044291cc69b44b547540

piskvorky gravatar imagepiskvorky ( 2011-12-12 22:15:46 -0500 )edit

@Evgeny: and btw what's the point of these askbot-specific settings vs. standard MEDIA_ROOT and MEDIA_URL?

piskvorky gravatar imagepiskvorky ( 2011-12-12 22:19:40 -0500 )edit

@piskvorky, we should remove the unnecessary custom variables, I agree with you.

Evgeny gravatar imageEvgeny ( 2011-12-15 18:12:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-12-11 17:36:58 -0500

Seen: 82 times

Last updated: Dec 11 '11