First time here? Check out the FAQ!

Unable to activate RSS Feeds

I missed probably one step to activate the RSS Feeds and no doc about this part of the configuration.


In I add:
1) According to :
from askbot.feed import RssLastestQuestionsFeed, RssIndividualQuestionFeed

2) The feeds dictionnary :
feeds = {
'rss': RssLastestQuestionsFeed,

3) The pattern :
{'feed_dict': feeds},

After restarting apache, the RSS link is always /feeds/rss/? and the feeds are inactives.

Any idea ?

tristan's avatar
asked 2012-04-29 13:18:29 -0500
edit flag offensive 0 remove flag close merge delete


add a comment see more comments

2 Answers


Ok, finally no problem : the site is under construction and protected by htaccess (the feed is unreachable).
To detect the error I used : which indicates clearly the nature of the error.

tristan's avatar
answered 2012-04-30 08:36:14 -0500
edit flag offensive 0 remove flag delete link


Thanks for the pointer, I will look at this by tomorrow. It might be the case that session-less clients have issues with some askbot urls.

Evgeny's avatar Evgeny (2012-04-30 08:40:45 -0500) edit

Ok, I misunderstood originally, it was just a site setup issue.

Evgeny's avatar Evgeny (2012-05-01 10:14:27 -0500) edit
add a comment see more comments

Tristan, the feeds are in the askbot/, so if you have 'askbot.urls' included in your you should have the feeds automatically.

If feed urls don't work that means you've changed something in your urls module. The defalut can be found in askbot/setup_templates.

Evgeny's avatar
answered 2012-04-29 13:33:33 -0500
edit flag offensive 0 remove flag delete link


The only changes I made are those described in the question... I go back to the original file but the feeds are not activated...

tristan's avatar tristan (2012-04-29 13:49:02 -0500) edit

I've just tested latest version - the feed urls work fine. On the hosted site we have the latest version too and the feeds work. Maybe you are missing migrations, or your INSTALLED_APPS is missing the feeds application. The sample settings file is also available in the askbot/setup_templates directory.

Evgeny's avatar Evgeny (2012-04-29 13:59:51 -0500) edit

I followed the doc for the deployment and i made the <code> migrate askbot</code> and <code> migrate django_authopenid</code>. What is the name of teh app for INSTALLED_APPS? I see nothing named *feed and my INSTALLED_APPS has the same value as the original...

tristan's avatar tristan (2012-04-29 14:34:25 -0500) edit

Same problem with a local test from scratch... I use the git version askbot-devel.

tristan's avatar tristan (2012-04-29 14:51:49 -0500) edit

I try to migrate another time but : <code>Nothing to migrate</code>

tristan's avatar tristan (2012-04-29 14:53:52 -0500) edit
add a comment see more comments