First time here? Check out the FAQ!

Stop gravatar

My site dont need gravatar. It is occupying some pixels. How Can I remove gravatar? Even want to show nothing but just name.


Zahid's avatar
asked 2012-08-08 21:01:55 -0500, updated 2012-08-11 23:05:42 -0500
edit flag offensive 0 remove flag close merge delete


I agree disabling gravatar is needed sometimes.

Nemo_bis's avatar Nemo_bis (2015-04-25 05:56:40 -0500) edit
add a comment see more comments

1 Answer


Go to "settings" -> "user settings" and disable the gravatars.

Evgeny's avatar
answered 2012-08-08 21:13:19 -0500
edit flag offensive 0 remove flag delete link


OK, but it still shows a mystery-man image. I want to show nothing. It is possible?

Zahid's avatar Zahid (2012-08-11 23:04:55 -0500) edit

Not at the moment. Maybe on the main page the mystery man should be removed, as they look ugly when you have more than 1. We might also hide automatic gravatars from the "contributors" block on the main page.

Evgeny's avatar Evgeny (2012-08-11 23:12:15 -0500) edit

Infact contributor block is not needed at all on home page. It is occupying lot of places on my side bar.

Zahid's avatar Zahid (2012-08-11 23:15:53 -0500) edit

@Zahid, I think on the contrary - people's faces are appropriate there, but you can disable it entirely if you want, by going to "settings" - "UI" - "Main page sidebar". I do agree that automatic gravatars and the mystery man are quite ugly.

Evgeny's avatar Evgeny (2012-08-11 23:20:43 -0500) edit
add a comment see more comments