Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I had a similar error.

In fact, I had

FATAL ERROR - The following SQL query failed: ALTER TABLE "auth_user" ADD COLUMN ...

The error was: column "..." of relation "auth_user" already exists

for each migrations which add a column to the auth_user model; and at the end of the installation, I can't create any question without an error saying that the column "is_private" doesn't exist in the table askbot_post. (Besides, I tried to install askbot with both mysql 5.0 an postgresql 9.1, and the problem was here only with postgresql.)

When I looked up a little, it seems that initially, when db is synced, the auth_user model is already correct, and all the migrations modifying it failed, in particular the 0124 which add the column "is_private" to askbot_post (and because I use the last version of psycopg2, it was rolled back), so I tried to delete all the adding and modifying of auth_user, and this worked ! But this was ugly ...

Then I looked up some more, and it seems that you patched the auth_user only in the initial migration, and not in the next ones, so I tried to use the safe_add_column method (instead of add_column) for all these adding, and once again it worked and it is much nicer :-)

I still have a fatal error on the migration 0014 that I can't explain, but I will look it in a few days.

(Ah, and just to let you know, it worked with mysql because south doesn't work well with my version of mysql (isn't it funny ;-) ))