First time here? Check out the FAQ!

MYSQL issue with migration 22 on install [fixed] migrate askbot gives the following error:

_mysql_exceptions.ProgrammingError: (1146, "Table 'graeme_investmentqa.pg_language' doesn't exist")

I managed to install by only migrating up to migration 21. This seems to be an acceptable workaround for the moment - at least it seems to work (I have some issues, but they are probably extra config needed for my host).

Also, the documentation does not mention that you also need to migrate askbot.deps.django_authopenid

Evgeny's avatar
updated 2010-11-01 09:54:42 -0500
graeme's avatar
asked 2010-11-01 09:30:56 -0500
edit flag offensive 0 remove flag close merge delete


add a comment see more comments

1 Answer


Thanks, fixed this. Next time the migration 22 will work (it will actually be a do-nothing) for MySQL as it should.

Evgeny's avatar
answered 2010-11-01 09:48:46 -0500
edit flag offensive 0 remove flag delete link


Thanks Evgeny. You are very helpful and you seem to fix problems very fast. Askbot is very easy to install (I used pip install in a virtualenv). The docs could be improved, but they are better than whats available for the alternatives.
graeme's avatar graeme (2010-11-01 15:13:14 -0500) edit
Graeme, you are welcome. Feel free to ask if you have any issues with your site or suggestions.
Evgeny's avatar Evgeny (2010-11-01 15:46:17 -0500) edit
I'm installing askbot 0.6.79 with MySQL (MyISAM). Migration 22 is still failing. I see that there is a condition in the migration code to only apply to postgresql. But, may be it is still expecting to see the pg_language table? Error: .../MySQLdb/", line 36, in defaulterrorhandler django.db.utils.DatabaseError: (1146, "Table 'askbot.pg_language' doesn't exist"
codedigger's avatar codedigger (2011-04-26 14:18:42 -0500) edit
Your setting DATABASE_ENGINE must be incorrect..... no? Is it "mysql" or "postgresql_psycopg2"? With "mysql" this migration must pass through without doing anything.
Evgeny's avatar Evgeny (2011-04-26 14:22:42 -0500) edit
OK, that was the problem! Even through I override with my with DATABASES = {...}, I guess DATABASE_ENGINE is a DIFFERENT setting, so it worked as far as db connection goes, but the migration script was still picking up DATABASE_ENGINE. Now all migrations worked. Thanks!
codedigger's avatar codedigger (2011-04-26 15:00:23 -0500) edit
add a comment see more comments