Ask Your Question
2

how to disable requests to gravatar.com?

asked 2011-11-09 05:55:10 -0500

Samuel's avatar

updated 2012-07-30 09:46:39 -0500

Evgeny's avatar

My Askbot instance is running into the private network of my company and has no authorized access to the web. An other aspect is that Credentials are managed with the internal LDAP. Even if is not critical, we do not want to create automatically records based on the emails in the gravatar database.

So, I would like to know what's the best way to disable requests to gravatar.com. Knowing that I want to keep the possibility to the user to upload the image he wants and it does not matter if the image by default is the same for all the users.

edit retag flag offensive close merge delete

Comments

Just an aside: Generating robot avatars using http://robohash.org/ could be a useful alternative to gravatar.

Joseph's avatar Joseph  ( 2011-11-16 03:30:21 -0500 )edit

We should get this done soon, someone is looking at this feature.

Evgeny's avatar Evgeny  ( 2011-11-24 12:13:44 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-07-30 09:50:13 -0500

bgenevaux's avatar

Well the matter I want to point is in the user_get_avatar_url function from models/__init__.py

In this function, we have :

            ...
            logging.critical(message)
            raise django_exceptions.ImproperlyConfigured(message)
    else:
        return self.get_gravatar_url(size)
else:
    ...

But shouldn't it be

        ...
            logging.critical(message)
            raise django_exceptions.ImproperlyConfigured(message)
    else:
        if askbot_settings.ENABLE_GRAVATAR:
            return self.get_gravatar_url(size)
        else:
            return self.get_default_avatar_url(size)
else:
    ...

in order to entirely disable requests to gravatar website?

edit flag offensive delete link more

Comments

Maybe, thanks I will look into this.

Evgeny's avatar Evgeny  ( 2012-07-30 10:23:28 -0500 )edit
1

answered 2012-07-30 09:43:35 -0500

Evgeny's avatar

This was solved: as admin go to "settings" ... -> "user settings" -> uncheck "use automatic avatars from gravatar.com".

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-09 05:55:10 -0500

Seen: 838 times

Last updated: Jul 30 '12