'Thread' object has no attribute 'question_denorm'

asked 2012-02-28 07:15:23 -0500

Olloff gravatar image

updated 2012-02-28 08:33:55 -0500

Evgeny gravatar image

Hello all.

Seems to be I have an html5lib issue too. I can't add question with any title in foreign language and receive a message "Title too long" on each try.

I tried to downgrade my html5lib to 0.90, but it has been not very effective. What can I do to fix that error?


Following error received after my try to add question with title on English

AttributeError at /vopros/4/ochen-dlinnaya-stroka-na-angliyskom

'Thread' object has no attribute 'question_denorm'

Request Method:     GET
Request URL:    http://help.sunline.ua/vopros/4/ochen-dlinnaya-stroka-na-angliyskom
Django Version:     1.3.1
Exception Type:     AttributeError
Exception Value:    

'Thread' object has no attribute 'question_denorm'

Exception Location:     /var/www/askbot/askbot/models/question.py in get_data, line 467

python: 2.5.2 over mod_wsgi askbot: git-dd7373e74f2097868eb2125e1a19a04f5bfb9002 html5lib: html5lib-0.90-py2.5.egg

//Будет ли удобным продолжать на русском?

edit retag flag offensive close merge delete

Comments

I don't think this is related to the html5lib issue... looks like a separate bug. Sorry here we'll have to stick to English for now as only minority understands Russian.

Evgeny gravatar imageEvgeny ( 2012-02-28 07:53:46 -0500 )edit

Looks like some threads do not have a question posts associated with them, a data anomaly, we'll post some fix to this soon.

Evgeny gravatar imageEvgeny ( 2012-02-28 08:34:59 -0500 )edit

Thanks for your help. If you need any information, feel free to ask.

Olloff gravatar imageOlloff ( 2012-02-28 08:53:50 -0500 )edit

Problem with "question_denorm" solved by another (prob. 3-rd) clean install from git. But I still have an "Title too long" issue and there is no log entries or errors which can explain that.

Olloff gravatar imageOlloff ( 2012-03-15 05:56:10 -0500 )edit