Ask Your Question
0

UnicodeEncodeError: 'ascii' codec can't encode characters

asked 2012-03-16 09:45:01 -0600

Olloff gravatar image

updated 2012-03-16 09:46:10 -0600

Hello, all!

Traceback (most recent call last):

 File "/var/src/askbot-devel/askbot_env/lib/python2.5/site-packages/Django-1.3.1-py2.5.egg/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/var/src/askbot-devel/askbot_env/lib/python2.5/site-packages/Django-1.3.1-py2.5.egg/django/views/decorators/csrf.py", line 39, in wrapped_view
   resp = view_func(*args, **kwargs)

 File "/var/src/askbot-devel/askbot_env/lib/python2.5/site-packages/Django-1.3.1-py2.5.egg/django/views/decorators/csrf.py", line 52, in wrapped_view
   return view_func(*args, **kwargs)

 File "/var/src/askbot-devel/askbot/views/writers.py", line 644, in delete_comment
   unicode(e),

**UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-7: ordinal not in range(128)**


<WSGIRequest
GET:<QueryDict: {}>,
POST:<QueryDict: {}>,
COOKIES:{},
META:{'DOCUMENT_ROOT': '/var/www/*EDIT*',
 'GATEWAY_INTERFACE': 'CGI/1.1',
 'HTTP_ACCEPT': '*/*',
 'HTTP_ACCEPT_ENCODING': 'gzip,deflate',
 'HTTP_CONNECTION': 'Keep-alive',
 'HTTP_FROM': 'googlebot(at)googlebot.com',
 'HTTP_HOST': '*EDIT*',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)',
 'PATH': '/usr/local/bin:/usr/bin:/bin',
 'PATH_INFO': u'/comment/delete/',
 'PATH_TRANSLATED': '/var/www/*EDIT*/django.wsgi/comment/delete/',
 'QUERY_STRING': '',
 'REMOTE_ADDR': '66.249.66.14',
 'REMOTE_PORT': '52071',
 'REQUEST_METHOD': 'GET',
 'REQUEST_URI': '/comment/delete/',
 'SCRIPT_FILENAME': '/var/www/*EDIT*/django.wsgi',
 'SCRIPT_NAME': u'',
 'SERVER_ADDR': '*EDIT*',
 'SERVER_ADMIN': '*EDIT*',
 'SERVER_NAME': '*EDIT*',
 'SERVER_PORT': '80',
 'SERVER_PROTOCOL': 'HTTP/1.1',
 'SERVER_SIGNATURE': '<address>Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_wsgi/2.5 Python/2.5.2 mod_perl/2.0.4 Perl/v5.10.0 Server at *EDIT* Port 80</address>\n',
 'SERVER_SOFTWARE': 'Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_wsgi/2.5 Python/2.5.2 mod_perl/2.0.4 Perl/v5.10.0',
 'mod_wsgi.application_group': '*EDIT*|',
 'mod_wsgi.callable_object': 'application',
 'mod_wsgi.listener_host': '',
 'mod_wsgi.listener_port': '80',
 'mod_wsgi.process_group': 'askbot2',
 'mod_wsgi.reload_mechanism': '1',
 'mod_wsgi.script_reloading': '1',
 'mod_wsgi.version': (2, 5),
 'wsgi.errors': <mod_wsgi.Log object at 0x4f82d20>,
 'wsgi.file_wrapper': <built-in method file_wrapper of mod_wsgi.Adapter object at 0x4f77d50>,
 'wsgi.input': <mod_wsgi.Input object at 0x490b9f0>,
 'wsgi.multiprocess': True,
 'wsgi.multithread': True,
 'wsgi.run_once': False,
 'wsgi.url_scheme': 'http',
 'wsgi.version': (1, 0)}>
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-03-21 05:51:56 -0600

Olloff gravatar image

Probably not bug, sorry. Fixed after upgrade to Python 2.6.6 along with some other warnings.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-03-16 09:45:01 -0600

Seen: 1,227 times

Last updated: Mar 21 '12