Ask Your Question
1

Add a more friendly name on your sender email!

asked 2012-06-05 07:04:56 -0600

zaf gravatar image

I found something nice and I want to share coz maybe you find it usefull too (most of you may already know).

On settings.py file you probably have a line where you set the email which all the outgoing emails will appear to have been sent from:

DEFAULT_FROM_EMAIL = 'do-not-reply@yourdomain.com'

Unfortunately, this do-not-reply appears also as the name of the sender, which, as you may agree, is not so nice.

The revolutionary code that will change your life is:

DEFAULT_FROM_EMAIL = 'Name Surname <do-not-reply@yourdomain.com>'

So at Name Surname you can put anything more friendly you want, like askbot team or askbot admin (of course not askbot but your site's name) and there you are, enjoy your new look :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-05 07:12:55 -0600

Evgeny gravatar image

updated 2012-06-05 07:22:41 -0600

Well, the point of this is to make it clear that nobody will read your response. If there is a name shown - the point may be lost. That said - you can of course modify the settings as you like.

Is there a name that would also give a clear message "do not reply to me"? Maybe we can put that into the default settings file template. It's nice that it is possible to add a formatted name to those email settings.

edit flag offensive delete link more

Comments

Well, still it's not nice to see mails from just 'do-not-reply'. There should be an indication about site's name, coz I receive mails from many sites that don't want to get reply.. You could have something like Askbot (do-not-reply) &lt;sender@yourdomain.com&gt;

zaf gravatar imagezaf ( 2012-06-05 07:55:08 -0600 )edit
1

That could work, could you try that kind of name? Are parentheses acceptable? Btw, I see a formatting error in the comment, something to fix too.

Evgeny gravatar imageEvgeny ( 2012-06-05 07:56:25 -0600 )edit

I haven't tried parentheses, hope they work, otherwise try other characters like [ or { or just omit them..

zaf gravatar imagezaf ( 2012-06-05 08:02:33 -0600 )edit

can you let me know if it works for you?

Evgeny gravatar imageEvgeny ( 2012-06-05 11:18:23 -0600 )edit

I just tested it. Bad news is that it ignores what is inside parentheses and with [ it doesn't work at all. Good news is that I tried with { and * and it works fine!

zaf gravatar imagezaf ( 2012-06-05 12:21:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-05 07:04:56 -0600

Seen: 185 times

Last updated: Jun 05 '12