Ask Your Question
1

Logout bug in Russian (and possibly other translations)

asked 2012-07-25 07:33:55 -0600

Toms gravatar image

updated 2012-07-26 15:26:40 -0600

On my ru locale site, I see the error 404 page after logging out.

instead of something like " successful logout .."

After logging out I'm redirected to:

http://mysite.com/account/signin/?next=/polzovatel/vyhod/

Edit: With this in settings.py

ASKBOT_TRANSLATE_URL = False

I get this url: http://mysite.com/account/signin/?next=/account/vyhod/

with 404 error

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-07-26 15:26:53 -0600

Toms gravatar image

updated 2012-07-27 05:33:03 -0600

Solution was:

ASKBOT_TRANSLATE_URL = False

and this in the django.po of ru locale

#: deps/django_authopenid/urls.py:10
msgid "signout/"
msgstr ""

now I have

http://mysite.com/account/vyhod/

And no error.

-------------------------------------

Edit: It is not necessary to set

ASKBOT_TRANSLATE_URL = False
edit flag offensive delete link more
1

answered 2012-07-25 16:05:10 -0600

Evgeny gravatar image

updated 2012-07-25 16:12:06 -0600

I think it is an error in the Russian translation of the url. Try setting

ASKBOT_TRANSLATE_URL = False

Does the problem go away?

This occurs because some urls are translated in two places - django.po and djangojs.po. Should be just in one place, otherwise there is a potential for the bugs like this one.

edit flag offensive delete link more

Comments

Hi @Evgeni! I've tried ASKBOT_TRANSLATE_URL = False, but unfortunately the problem is still there.

Toms gravatar imageToms ( 2012-07-26 15:09:06 -0600 )edit

Ok, I got the solution. See update. Your hint was correct. Thanks

Toms gravatar imageToms ( 2012-07-26 15:20:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-25 07:33:55 -0600

Seen: 276 times

Last updated: Jul 27 '12