Ask Your Question

Revision history [back]

How can I configure the Google+ login?

Hey there,

I saw that that recently a commit fixed the Google+ login system. So I tried it but I'm having a problem. Here is what I've tried to do:

  1. Created the credential for Google+ API and inserted both public and secret API keys at the "settings/EXTERNAL_KEYS/" URL. (Q: Why are there 2 boxes for each of those?)
  2. Then I tried to setup the "Google Plus Login" box at "settings/LOGIN_PROVIDERS/"
  3. Strangely the box for that service was already marked (together with a couple of others). Then I went to confirm at the database, and everything was set to FALSE. I set the one for G+ to TRUE and then the button appeared!
  4. I tried to login with it and initially I got a configuration error, because I didn't know what URL to insert at the "Authorization redirect URI" at the Google+ API configuration. I used "<my_server_domain>/account/signin/complete-oauth2/" and it went through.
  5. But now I have the following error and I don't know what to do...

Request Method: GET
Django Version: 1.8.13
Exception Type: KeyError
Exception Value:    u'google-plus'
Exception Location: /var/lib/.../askbot/deps/django_authopenid/views.py in complete_oauth2_signin, line 256
Python Version: 2.7.8

Can anyone help? Is this something related to "django_authopenid" library version? I don't know how to check that as it is part of the settings of the django project.