Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

unable to configure askbot

While running a syncdb I got this following error:

(site)[sayan@fedora forum]$ python manage.py syncdb
Traceback (most recent call last):
  File "manage.py", line 11, in <module>
    execute_manager(settings)
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/core/management/__init__.py", line 438, in execute_manager
    utility.execute()
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/core/management/__init__.py", line 379, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/core/management/base.py", line 191, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/core/management/base.py", line 219, in execute
    self.validate()
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/core/management/base.py", line 249, in validate
    num_errors = get_validation_errors(s, app)
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/core/management/validation.py", line 36, in get_validation_errors
    for (app_name, error) in get_app_errors().items():
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/db/models/loading.py", line 146, in get_app_errors
    self._populate()
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/db/models/loading.py", line 61, in _populate
    self.load_app(app_name, True)
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/db/models/loading.py", line 78, in load_app
    models = import_module('.models', app_name)
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/utils/importlib.py", line 35, in import_module
    __import__(name)
  File "/home/sayan/Development/mether/askbot-devel/askbot/models/__init__.py", line 2, in <module>
    startup_procedures.run()
  File "/home/sayan/Development/mether/site/lib/python2.7/site-packages/django/db/transaction.py", line 217, in inner
    res = func(*args, **kwargs)
  File "/home/sayan/Development/mether/askbot-devel/askbot/startup_procedures.py", line 478, in run
    run_startup_tests()
  File "/home/sayan/Development/mether/askbot-devel/askbot/startup_procedures.py", line 443, in run_startup_tests
    test_staticfiles()
  File "/home/sayan/Development/mether/askbot-devel/askbot/startup_procedures.py", line 353, in test_staticfiles
    url = urlparse(static_url).path
  File "/usr/lib/python2.7/urlparse.py", line 134, in urlparse
    tuple = urlsplit(url, scheme, allow_fragments)
  File "/usr/lib/python2.7/urlparse.py", line 173, in urlsplit
    i = url.find(':')
AttributeError: 'NoneType' object has no attribute 'find'