Ask Your Question
1

failed to install(askbot-setup) in askbot 0.11.x

asked 2019-07-09 23:00:13 -0600

vish gravatar image

updated 2019-11-22 02:40:12 -0600

I have cloned askbot 0.11.x version and trying to deploy it. when I'm running python setup.py develop it's installing and setting up askbot version 0.10.2. so that I've uninstall askbot. askbot-setup command giving error command not found

how to install and setup 0.11.x version?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-07-10 14:38:46 -0600

martin-bts gravatar image

updated 2019-07-10 14:40:30 -0600

To install the current 0.11.x branch, the best approach is imitating the procedure used in the Dockerfile:

  1. install Askbot's requirements

    pip install -r askbot_requirements.txt
    
  2. install Askbot

    python setup.py install
    
  3. create a new Django project with Askbot as its only app using askbot-setup. The most basic approach is

    askbot-setup \
        -n /path/to/new/django/project \
        -e 2 -d /path/to/new/django/project/db.data \
        --create-project django
    

    For more options run askbot-setup --help. You can look at the Dockerfile for an example that uses PostgreSQL as database backend.

  4. setup database and staticfiles

    cd /path/to/new/django/project
    export DJANGO_SETTINGS_MODULE=askbot_app.settings
    python manage.py migrate
    python manage.py collectstatic
    

After that you can setup your webserver, the Django project and the database to your requirements and start using Askbot.

If you are looking for a canonical deployment to try out Askbot, I'd suggest you first build and then run a docker image using the provided Dockerfile.

docker build -t askbot:latest --build-arg ASKBOT=. .
docker run \
    -e 'DATABASE_URL=sqlite:////askbot-site/askbot.db' \
    -e "SECRET_KEY=$(openssl rand 14 | base64)" \
    -e ADMIN_PASSWORD=admin \
    -p 8080:80 \
    askbot:latest
edit flag offensive delete link more

Comments

Successfully completed the setting up askbot 0.11.x. thank you for the guidance and help. I have used MySQL as database. First I tried with MySQL Server version: 5.5, but it was giving the error raise MigrationSchemaMissing("Unable to create the django_migrations table (%s)" % exc)django.db.migrations.exceptions.MigrationSchemaMissing: Unable to create the django_migrations table ((1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(6) NOT NULL)' at line 1")) That issue fixed after installing MySQL Server version: 5.6.

vish gravatar imagevish ( 2019-07-12 04:20:47 -0600 )edit

From the fine manual at `https://docs.djangoproject.com/en/2.2/ref/databases/`: Django supports MySQL 5.6 and higher.

martin-bts gravatar imagemartin-bts ( 2019-07-12 08:43:36 -0600 )edit

why notifications or inbox section not display in askbot 0.11.x version?

alnuaimi94 gravatar imagealnuaimi94 ( 2019-07-30 07:01:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-09 23:00:13 -0600

Seen: 1,145 times

Last updated: Nov 22